ParaView 5.0.1 Release Notes

ParaView 5.0.1 is now available for download. This is a patch release that addresses some critical issues reported in the 5.0.0 release. Since this is a patch release, users using ParaView in client-server configurations can continue to use a  5.0.0 server with a 5.0.1 client if necessary (but not vice versa), although using 5.0.1 server is highly recommended.

Some of the issues addressed by this release are:

  • Remote rendering with translucent geometry or volume rendering had artifacts due to the image compression algorithm used for delivering rendered images to the client. This is now fixed by adding a new compression algorithm (LZ4). LZ4 is now the default compression algorithm used for delivering images in client-server mode, instead of SQUIRT.
  • ‘Ray Cast Only’ option was accidentally removed from the available volume mapper choices when volume rendering 3D image datasets. This has been fixed.
  • Fixed Axes Grid disappearing when using parallel projection.
  • Arrays from Field Data were accidentally being listed in array selection widgets for filters like Threshold. Fixed that.
  • Fixed run-time issues with executing Python scripts generated using ParaView’s tracing capabilities when the pipeline had multiple output ports.
  • Several fixes for volume rendering have gone into this release including fixing issues with volume rendering using cell data arrays.

For a complete set of changes merged into this release, please refer to the Gitlab page and the bug tracker.

Besides 64-bit binaries for Linux, OsX and Windows, we have brought back the 32-bit Windows binaries with this release. The 64-bit Windows binaries are available in two flavors: without MPI and with MPI. The binaries with MPI require that Microsoft MPI is already installed on the target system.

 

2 Responses to ParaView 5.0.1 Release Notes

  1. Martin Bittens says:

    Question: where I can find the system requirements of ParaView 5.0.1? I can open PV but it tells me that my graphic driver does not support GL version 2.1 which is required by the new OpenGL rendering backend – whatever it is. Would be great if somebody can hel me.

  2. Utkarsh Ayachit says:

    ParaView 5.0 and greater recommends OpenGL 3.2 or newer. OpenGL 2.1 may work provided certain extensions like GL_EXT_gpu_shader4 are supported.

Questions or comments are always welcome!